Brightree Update - While some improvement has been observed, our teams continue to actively monitor Brightree performance and investigate the issue. Updates will be provided as they become available.
Posted Feb 03, 2026 - 15:30 EST
Investigating
Brightree has reported: We are aware that some users are experiencing slowness within Brightree. Our teams are currently investigating and will provide updates as they become available.
Posted Feb 03, 2026 - 11:59 EST
This incident affected: 3rd Party Service - Brightree (Brightree).