Intermittent Paylocity Suite Degradation

Incident Report for Barnes Healthcare Services

Resolved

This morning, some users were experiencing difficulty logging into paylocity.com. At 8:50AM CT, Paylocity resolved this issue. Access to paylocity.com is restored, and all systems are functioning normally.
Posted Jan 24, 2026 - 16:44 EST

Update

There have been no further updates from Paylocity regarding this incident. It was initially reported as intermittent, so if you run into issues, please try again after a few minutes. I will officially close this out after getting a resolution from Paylocity.
Posted Jan 23, 2026 - 17:03 EST

Update

Here is Paylocity's latest update:

Beginning at 6:41 a.m. CT, some users are experiencing difficulty logging into Paylocity. We're aware of the issue and are working to resolve it as a top priority. Some users are reporting success by switching ISP providers, using mobile hotspots, or resetting routers. We'll follow up with more information as it becomes available or upon resolution.
Posted Jan 23, 2026 - 11:36 EST

Investigating

Beginning at 6:41 a.m. CT, some users are experiencing difficulty logging into paylocity.com. We're aware of the issue and are working to resolve it as a top priority. We'll follow up with more information as it becomes available or upon resolution.
Posted Jan 23, 2026 - 08:59 EST
This incident affected: 3rd Party Service - Paylocity (Paylocity).